Registration Error

Mar 31, 2011 at 4:35 AM

First, thank you for providing this toolkit.

It seems that I can not get through the registration process from the empty solution...

Although I've installed the certificate on the phone emulator, I'm still receiving the following message: 

"Registration Error [...] Please make sure to install the SSL certificate on the phone".

On the same hand, when I debug the Azure project, and click on the Continue to this website (not recommended), I'm landing on an empty page instead of the WP7  Cloud Application - services...

I've checked my local IIS (no website on port 443 and/or 10080) and Computer Emulator is running on the right ports...

Any help to resolve this issue would be greatly appreciated...


Apr 1, 2011 at 4:17 PM

Sorry for the trouble you're having. A few questions:

  • Are you deploying the phone app to a device or to the Windows Phone Emulator?
  • Are you using the "Windows Phone 7 Cloud Application" project template or the "Windows Phone 7 Empty Cloud Application" one? If you are using the latter one, where did you get the phone application from?
  • Did you modify the endpoint configuration in the App.xaml file?
  • Are you able to register a new user from the Web role at

If you could provide more details that you think may also be relevant I‘ll really appreciate it.
Just in case, you can check the Troubleshooting section where there is a similar error to the one you described, though it is related to a port problem.


Apr 1, 2011 at 11:45 PM
  • I'm deploying on the Windows Phone Emulator
  • I've tried both but I'm now using the Cloud application (not the empty one).
  • I did not modify the endpoint configuration in the App.xaml file (Should I?)
  • I get a "HTTP 404 Not Found" when I try to access

However, I'm able to install the certificate on the WP7 Emulator but when I try to login as an admin, I get an error asking to install the SSL certificate that I've just installed in the step before...

I've looked at the Troubleshooting section but my the endpoints are on the right ports.

When I start a new instance from the Cloud project, I'm landing on the certificate warning page. Then when I click on the Continue to this website (not recommended) link, i'm landing on a blank page...

Have you seen this behaviour before? Your help is greatly appreciated...






Apr 10, 2011 at 6:03 PM


I'm having a problem that appears identical to Steve's.

I installed the certificate using the phone emulator, but I receive an identical error message as Steve's when I try to register.
And similarly, when I try to view the localhost webpage opened by the template "Windows Phone 7 Cloud Application", I have not been able to view the admin page that's displayed in the video tutorial/walkthrough. Rather, I just get an empty page.

I am deploying using the Windows Phone Emulator, I have not modified App.xaml, and I am not able to register a new user. (Indeed, is a blank page as well.)

I followed the Troubleshooting link, and the services are running over the correct ports (and I have checked that nothing is running on those ports).

Steve, in case you check back, did you manage to resolve your problem?



Apr 10, 2011 at 10:45 PM

Steve (and Wade),

I was just able to fix this error, so if our problem is in fact the same (you had identical symptoms to me), the following might be useful:

(HUGE DISCLAIMER: I am actually unsure of the exact piece that finally fixed it. I just kept browsing Google and trying things - a shotgun approach, I suppose. Hopefully my description will help Wade or someone else identify the exact, correct steps.)

Overall, I now believe this is related to configuration options of IIS and WCF HTTP Activation. As I'm not nearly enough of an expert on this, take the following as suggestions, but absolutely *not prescriptive* by any means. Here is a description of what I did, with zero guarantee of correctness implied:

1. Turned on WCF HTTP Activation.

Control Panel -> Programs and Features -> Turn Windows Features on or off -> Microsoft .NET Framework 3.5.1 -> Check "Windows Communication Foundation HTTP Activation"

2. ...which caused the following error to appear instead of a blank page: "Could not load type 'System.ServiceModel.Activation.HttpModule' "

...which led me to this page for a fix:

(Here is a related explanation of a (possible?) cause: )

3. To reiterate, I have no idea if any of that actually helped, but then I noticed on the Windows Features dialog box, next to the .NET Framework options, there were options for Internet Information Services (IIS). I opened up the sub-menu, and checked every box that looked reasonable (Yes, I realize how awful that sounds...). But, after doing so, ta-da, it worked (finally).


At the least, hopefully that tips someone off who knows what's going on. I'd really recommend NOT attempting to follow my exact steps unless you have an idea of what's what!


May 5, 2011 at 2:54 PM

Hi I have issues related to what's been described in this thread. When I run the template project (WP cloud, not the empty one), the browser opens to
When I click on "Continue to this website (not recommended)", it takes like 5-10 min for anything to happen, and then I see the ASP.NET page with the PortErrorMessage (web role started in a wrong port).

When I look in the Compute Emulator service details, I see :

WP7CloudApp1Contract     WP7CloudApp1.Services.Endpoint2   http://*:10080
WP7CloudApp1Contract    WP7CloudApp1.Services.Endpoint1    https://*:443

If I change 443 to 445 in the solution, for example, then I see :

WP7CloudApp1Contract      WP7CloudApp1.Services.Endpoint1      https://*:445
(so always +1 from the URL port to the IP Address port)

May 6, 2011 at 1:36 PM

OK fixed this pb by following Michael Collier's suggestions here :

Basically, I turned off my default website.

Now the service runs on the correct default port, but it still takes like 10 min for the home web page to display at start, and eventually the server outright CRASHES! I'm filing this in the issue tracker

May 13, 2011 at 12:54 PM

I had same problem. Azure web application was starting on port 444. I checked who uses port 443 (cmd -> netstat -ano -> lookup process id in task manager) and found that Skype uses port 443. So I uncheked Skype option to use ports 80 and 443 as alternative ports, and restarted it. I also restared Azure Emulator. After that, web application regulary started on port 443.