Role instances are taking longer than expected to start

Apr 1, 2011 at 5:22 AM

Hi Wade, when running the web role project on my local dev fabric, I get this error "Roles instances are taking longer than expected to start.  Do you want to continue waiting?"  Any idea on where I could start troubleshooting? 

(Btw the pre-release version of this worked for me, the one you asked internal folks to test ;)  - chism@microsoft )

- Chris

Coordinator
Apr 1, 2011 at 5:16 PM

Sorry for the trouble you're having. We are aware of this problem and we are working on a solution for the next release.

As a workaround you could try the following:

  • Close all Visual Studio instances.
    Close the Compute and Storage Emulators.
    Navigate to the %SolutionName%.Services folder and open the %SolutionName%.Services.csproj.user file with Notepad.
    Make sure that the AlwaysStartWebServerOnDebug element is set to False.
    Open the solution and run it again.

Thanks,
Wade

Apr 5, 2011 at 2:35 PM

Hi Wade, I checked and yes it is set to False.  I will try looking for the solution to this as well.

Apr 5, 2011 at 4:08 PM

Ok weird, I reinstalled SQL Server Express, ran DInst and it's working now.  The reason I tried that is because my Storage Emulator wasn't working when I tried just now.  So it must be my Storage Emulator.  (Although I'm quite sure the Storage Emulator was running before when I first encountered this error because I was able to run a barebones web role in VS2010).  I hope this helps someone else.