Starting up the Web Role

Apr 27, 2011 at 3:48 PM

After creating a new Windows Phone 7 Cloud Application project and then following the instructions I get the following error when I choose to 'Continue to the website (not recommended)...'

WP7CloudApp2.Services.Infrastructure.RoleInWrongPortException: The Web role was started in a wrong port. For this sample application to work correctly, please make sure that it is running in port 443. Please review the Troubleshooting section of the sample documentation for instructions on how to do this.

I checked the Troubleshooting section and my web role is running on the correct ports.

Any help would be appreciated.

Note, for demo purposes is there anyway I could disable the use of certificates...the application I would like to create is not going to be 'Released To Market' but instead as demonstrator only.

May 25, 2011 at 11:06 PM

Hi.

Your mileage may vary, but here's the solution that worked for me.

/Magnus

Jun 7, 2011 at 9:22 AM
Thank you


From: [email removed]
To: [email removed]
Date: Wed, 25 May 2011 15:06:40 -0700
Subject: Re: Starting up the Web Role [watoolkitwp7:255444]

From: MagnusJ
Hi.
Your mileage may vary, but here's the solution that worked for me.
/Magnus
Read the full discussion online.
To add a post to this discussion, reply to this email (watoolkitwp7@discussions.codeplex.com)
To start a new discussion for this project, email watoolkitwp7@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Jul 30, 2011 at 6:00 PM

Hi! I cant run the app, still redirection on port 443. I figured out the process that runs on port 443, but it is W3SVC. I cant kill this process.

Anyone can help me?

 

Aug 4, 2011 at 2:37 PM

You can't kill it because you have another application running on 443 using IIS?  If you are trying to access this development machine from another one (like if you are trying to run this on a test server) it won't work as it only works with the local host.

So, unless you are running and debugging on your local machine on 443, you should be able to close it...?  443 is also hijacked by skype btw.