Role instances are taking longer than expected to start

May 22, 2011 at 5:49 PM

I have searched about this error with no resolution that helps me.

Basically, I installed the toolkit and tried both Standard and Empty WP7 Cloud projects. I then right-click the Cloud project and select to debug it. This is using either my credentials or the developer option.

The Compute Emulator is started but continually restarts until the "taking longer than expected" error displays.

Viewing the compute emulator deployment console shows:

[fabric] Role Instance: deployment...
[fabric] Role state Busy
[fabric] Role state Stopping, Stopped, Aborted, Teardown, Destroyed, Created, Suspended, Busy, Stopping, etc...

Removing the <sites> from the config did not help.

Thanks,

Gary Davis

Coordinator
May 22, 2011 at 6:34 PM
Edited May 22, 2011 at 6:37 PM

Sorry for the trouble, Gary.  We have a fix for this problem that we are testing.  I should have the update tomorrow (along with an explanation).  For now, try the following:

  • Close Visual Studio.
  • Shut down the compute emulator.
  • Browse to your Windows Azure Project and delete the .user file.
  • Open up your solution and try again.

Sorry for the hassle!

Thanks,

Wade

May 22, 2011 at 7:29 PM

Thanks for the quick response, Wade. I found two .user files (csproj.user and ccproj.user) and removed them both. That solved the "taking longer" problem. After comparing, it seems the csproj file was the one that changed (in the .Web project).

I now see this error dialog (I also saw it once before the problem was resolved):

There was an error attaching the debugger to the IIS worker process for URL 'https://127.0.0.1:5100/' for the role instance 'deployment(25).WP7CloudApp2.CloudApp2.Web.0'...

I'll continue poking around to try different things.

Thanks,

Gary

Coordinator
May 22, 2011 at 7:49 PM

It shouldn't try to use 5100 for https, but rather 443.  Do you have 443 used in IIS somewhere?  If not, then most likely the compute emulator needs to be restarted as it looks like it is reserving the port 443.

May 22, 2011 at 10:31 PM

Thanks again, Wade. Yes, it turned out 443 was in use. The culprit was Skype (found using the TcpView SysInternals tool). There is an option in Skype (Advanced->Connections) to turn off use of ports 80 and 443, generally not needed.

The Compute Emulator now shows port 443 in use instead of 444 for Web.Endpoint1. I still get an error, however. This is a bit different than above (port 5101):

There was an error attaching the debugger to the IIS worker process for URL 'https://127.0.0.1:5101/'...

Thanks again,

Gary

May 24, 2011 at 1:33 AM

Since I could not get very far with the template app (attach problem above), I decided to try going the legacy (non-IIS) route.

I removed the <Sites> from the ServiceDefinition.csdef and shutdown the Compute Emulator. I first started the Cloud app and this time it brough up the web role OK. Next, I started the phone app instance and it deployed and started up.

The problem now is that clicking the Install Cert link brought up the browser with no URL. I tried typing in the url to the 127.0.0.1.cer file but it then displayed in the phone emulator browser window the Sorry... error indicating an exception of type "System.Exception" was thrown.

Any ideas?

Thanks,

Gary