Empty Cloud Application Fails to create sub project 'Libs'

May 26, 2011 at 3:44 AM

I'm using VS Express for WP on a Win7 x86 VM. 

When I try to create a new Empty Cloud Applicaiton I am prompted with a dialog that reads:

  • "A problem was encountered creatin the sub project 'Libs'.  Object reference not set to an instance of an object."

The libs directory is empty.  I have no problem creating the example project.  The Libs folders in those projects contain 2 dll's System.Data.Services.Client.dll and WindowsPhoneCloud.StorageClient.dll

I suspect a work around is just to copy over those dlls to the empy libs directory and fix up the references.  I'll give that a try.

John ...





May 26, 2011 at 3:56 PM

Hi John,

Thanks for reporting this error. We’ll make sure to fix it in the next release of the toolkit.

As you suggested, the workaround is to copy the System.Data.Services.Client.dll and WindowsPhoneCloud.StorageClient.dll assemblies from the %TookitInstallationFolder%\Binaries folder to the Libs folder generated by the templates.

Thanks and apologies for the inconveniences!


May 26, 2011 at 11:55 PM

Thanks for the work on the toolkit.  I had investigated developing a Windows Phone app back in November.  One of the reasons that I abandoned the effort was due to the amount of work surrounding Push Notification and user management.  This toolkit is allowing me to revive that effort.  It was really easy to get the sample up and running and step throough the code.  I have a much better understanding regarding how it all fits toghether now.  Thanks,  John ...