Toolkit dependency checker fails on "WCF HTTP activation feature enabled".

Jun 28, 2011 at 3:09 PM

I'm trying to install the WAZ toolkit but am unable to due to the error mentioned in the title.

If I try the offered "install" link, I get a CMD box that says "Installing .NET WCF HTTP Activation, please wait", but nothing happens. I've checked that .NET 3 HTTP activation is enabled in the control panel (it is).

I'm well out of my depth here, I just want to make a game!

Jun 29, 2011 at 12:16 AM

I discovered that you can right click on any of the items in the dependency checker and choose to "ignore" the result, which subsequently let me install the VS templates (I was fairly certain it was mis-diagnosing the fact that WCF HTTP activation was not enabled).

 

That being said, I still can't run the initial project completely as it will not create the web service on port 443, it always creates it on 444!

Jun 29, 2011 at 12:26 PM

All working now, but I've had to do almost all of the suggested "fixes" mentioned in this admittedly quite helpful forum. So to recap:

Vista 32bit VS2010 Pro. Attempting to run the sample app in "local" mode using the Azure emulators.

1) The dependency checker incorrectly said .NET WCF ACTIVATION was inactive. I right clicked to skip this dependency.

2) Noticed the Azure compute emulator had bumped the service to Port 444. Using a great little utility called CURRPORTS, I, like others, discovered Skype was hogging 443.

3) Turned on HTTP redirection.

4) Deleted the user file in the application directory.

5) Rebooted.

It does take around 10 minutes to start after hitting F5, and it does bring my dev machine to its knees. I'm guessing the Azure emulators are quite hungry? Time to get my Azure account.