Setup.cmd Dependency Checker Fails On Silverlight for Windows Phone Toolkit 7.1

Oct 28, 2011 at 6:14 PM

I can't install/use the toolkit.  When I run Setup.cmd in the root, the Dependency Checker tool Fails to find the Silverlight for Windows Phone Toolkit 7.1 that I just installed from here:

http://silverlight.codeplex.com/releases/view/71550

"Silverlight for Windows Phone Toolkit - Aug 2011.msi"

I am unable to click "Skip or Next" at the bottom of the wizard so I have to cancel it.

I went into "\WindowsAzure\WATWindowsPhone.C#\Setup\dependencies.depi" and manually changed disableSkip="true" to disableSkip="false" for name="Microsoft Silverlight for Windows Phone Toolkit" and it allowed me to choose "Skip" on that specific dependency but I didn't want to continue the intsall in case something deeper is wrong that would prevent it from working or mess up my Visual Studio install.

Anyone know how to resolve this dependency error properly?  I reinstalled Microsoft Silverlight for Windows Phone Toolkit twice using the msi above and still doesn't work.